Γενικά

Ηλεκτρονικός Λογογράφος

Ο ηλεκτρονικός λογογράφος, χρησιμοποιώντας την πλέον σύγχρονη τεχνολογία αναγνώρισης συνεχούς λόγου, μπορεί με ακρίβεια να καταγράφει τα λεγόμενά σας. Αφού εγκαταστήσετε το μικρόφωνο που συνοδεύει το πρόγραμμα, μπορείτε να υπαγορεύσετε το κείμενο που θέλετε, εισάγοντας ακόμα και σημεία στίξης, και, στη συνέχεια, απλά με το πάτημα ενός κουμπιού, ο ηλεκτρονικός λογογράφος μετατρέπει τον προφορικό σας λόγο σε γραπτό. Γράφει ελληνικά για εσάς. Επιπλέον, το περιβάλλον του προγράμματος, με κάποια επιπρόσθετα εργαλεία μορφοποίησης, σας επιτρέπει να φέρετε το κείμενο στην τελική του μορφή, είτε αυτό είναι κείμενο αλληλογραφίας, άρθρο, ημερολόγιο ή απλά ιδέες που θέλετε να καταγράψετε.

Η γραφική διεπαφή με τον χρήστη:


Αρχικές Ρυθμίσεις

Ρυθμίσεις Ηλεκτρονικού Λογογράφου

Προκειμένου να βελτιστοποιήσετε τη λειτουργία του συστήματος μπορεί να χρειαστεί να ακολουθήσετε την παρακάτω διαδικασία:

  1. Με την επιλογή του κουμπιού [image] από τη μπάρα εργαλείων είναι δυνατή η σωστή ρύθμιση του μικροφώνου στην κατάλληλη ένταση ώστε να είναι βέλτιστες, κατά το δυνατόν, οι συνθήκες ηχογράφησης. Η ρύθμιση γίνεται με τη βοήθεια του γνωστού εργαλείου των Windows.

  2. Επιλέγετε 'Properties' από το μενού 'Options' και στην οθόνη που εμφανίζεται, επιλέγετε 'Recording'.

  3. Στη συνέχεια, πατώντας το κουμπί 'OK' μπορείτε να ρυθμίσετε την ένταση με την οποία ηχογραφεί το μικρόφωνο χρησιμοποιώντας το εργαλείο που εμφανίζεται.

  4. Κάντε διάφορες δοκιμές προκειμένου να επιτύχετε τις καλύτερες δυνατές ρυθμίσεις, ανάλογα με το θόρυβο στο χώρο όπου βρίσκεστε αλλά και τις απαιτήσεις που έχετε.


Ηχογράφηση-Αναγνώριση

    Πληροφορίες σχετικές με την Ηχογράφηση-Αναγνώριση

  1. Με την επιλογή του κουμπιού [image] ξεκινάει η ηχογράφηση και μπορείτε να ξεκινήσετε την υπαγόρευση. Προσπαθήστε να μιλάτε καθαρά και με ένταση τέτοια ώστε η μπάρα στο πάνω δεξιό μέρος της οθόνης να μην "κοκκινίζει" - γι' αυτό σημαντικό ρόλο παίζει και η ρύθμιση της έντασης του μικροφώνου, όπως περιγράφεται στο κεφάλαιο 'Αρχικές Ρυθμίσεις'.

  2. Στο κάτω αριστερά μέρος της οθόνης εμφανίζεται μήνυμα ότι ηχογράφηση βρίσκεται σε εξέλιξη.

  3. Τελειώνοντας το κείμενο που θέλετε να υπαγορεύσετε, πρέπει να σταματήσετε την ηχογράφηση για να ξεκινήσει η διαδικασία αναγνώρισης. Για το σκοπό αυτό ξαναπατήστε το κουμπί [image] . Αυτομάτως ξεκινάει η αναγνώριση του κειμένου που μόλις υπαγορεύσατε και σύντομα θα αρχίσει να εμφανίζεται στην οθόνη το μέρος του κειμένου που έχει αναγνωριστεί. Αρχικά, μπορεί να είναι με κόκκινο χρώμα, γεγονός που φανερώνει ότι ακόμα δεν έχει ολοκληρωθεί η διαδικασία. Εντωμεταξύ στο κάτω αριστερά μέρος της οθόνης εμφανίζεται μήνυμα ότι αναγνώριση είναι σε εξέλιξη (Recognition in Progress)μέχρι να ολοκληρωθεί η διαδικασία .

  4. Είναι πιθανό σε κάποιες περιπτώσεις να χρειαστεί να διακοπεί η διαδικασία αναγνώρισης. Μια τέτοια περίπτωση παρουσιάζεται όταν έχει γίνει κακή ηχογράφηση οπότε το σύστημα καθυστερεί υπερβολικά να δώσει αποτελέσματα. Το κουμπί [image] , το οποίο είναι ενεργό μόνο στη φάση της αναγνώρισης, μπορεί να χρησιμοποιηθεί ακριβώς για να διακόψει τη διαδικασία αυτή.

Σημειώσεις σχετικές με την υπαγόρευση κειμένου:

  1. Σχετικά με τα σημεία στίξης :
    • Θαυμαστικό !

    • Κόμμα ,
    • Τελεία .
    • Ερωτηματικό ;
    • Παύλα -

    Πρέπει να προφέρονται με το πρόθεμα "βάλε".

    Π.χ. "βάλε τελεία"

  2. Σχετικά με τις παρενθέσεις, αυτές προφέρονται:

    3.

    "Άνοιξε παρένθεση "
    "Κλείσε παρένθεση"

    Και αντίστοιχα για τα εισαγωγικά:

    " Άνοιξε εισαγωγικά "
    "Κλείσε εισαγωγικά"

  3. Τέλος το σύμβολο % προφέρεται "επί τοις εκατό"

    4.


Επιπλέον Δυνατότητες

Επιπλέον Δυνατότητες Ηλεκτρονικού Λογογράφου

  • Ο ηλεκτρονικός λογογράφος παρέχει επίσης δυνατότητες μορφοποίησης του κειμένου που έχει αναγνωριστεί (βλ. Μορφοποίηση_Κειμένου). Έτσι, μπορείτε για παράδειγμα να αλλάξετε τη γραμματοσειρά, να κάνετε αντιγραφή και επικόλληση και άλλες κλασσικές (στο περιβάλλον Windows) μετατροπές.

  • Με την επιλογή "Tools" από το μενού έχετε τις παρακάτω επιλογές :

    1. Μπορείτε να ακούσετε τι ηχογραφήσατε την τελευταία φορά ("Hear"). Η επιλογή αυτή μπορεί να χρησιμοποιηθεί για έλεγχο.
    2. Μπορείτε να σταματήσετε την ακρόαση ("Stop").

    Για τις δύο αυτές επιλογές υπάρχει και αντίστοιχο κουμπί στην μπάρα εργαλείων - [image].

  • Με την επιλογή Options από το μενού μπορείτε να πραγματοποιήσετε πρόσθετες ρυθμίσεις που αφορούν στον τρόπο εμφάνισης των αριθμών στο μορφοποιητή κειμένου του Ηλεκτρονικού Λογογράφου αλλά και λέξεων που προέρχονται από την Αγγλική γλώσσα και χρησιμοποιούνται συχνά στην καθομιλουμένη.
    Εμφανίζεται το παράθυρο :

    Στο πάνω μέρος του παραθύρου ( 'Conversion of typical english words to :' ) μπορείτε να επιλέξετε αν θέλετε συνηθισμένες αγγλικές λέξεις ( όπως για παράδειγμα computer , video , internet κ.ά. ) να εμφανίζονται γραμμένες στα Ελληνικά ( επιλογή 'Greek' ) ή στα Αγγλικά ( επιλογή 'English' ).

    Παράδειγμα:
    • 'English':
      Το video χρησιμοποιήθηκε στη δίκη.
    • 'Greek':
      Το βίντεο χρησιμοποιήθηκε στη δίκη.

    Στο κεντρικό τμήμα του παραθύρου ( 'Representation of numbers as :' ) μπορείτε να επιλέξετε αν θέλετε οι αριθμοί να εμφανίζονται αριθμητικώς ( επιλογή 'Digits' ) ή ολογράφως ( επιλογή 'Words' ).

    Παράδειγμα:
    • 'Digits':
      Η επανάσταση έγινε το 1821.
    • 'Words'
      Η επανάσταση έγινε το χίλια οχτακόσια εικοσιένα .

    Σημειώνεται ότι στην περίπτωση εκφώνησης διαδοχικών αριθμών , αν έχει επιλεγεί η αριθμητική τους αναπαράσταση , τότε αυτό που στο τέλος εμφανίζεται είναι το άθροισμά τους . Αν θέλετε απλά να εμφανιστούν διαδοχικά οι αριθμοί τότε πρέπει να εκφωνήσετε κάποιο διαχωριστικό ανάμεσά τους , όπως 'βάλε κόμμα' , ή 'βάλε παύλα' .

    Παράδειγμα:
    • Επιλογή 'Digits':
      1. Εκφώνηση : ' δύο τρία τέσσερα πέντε '
        Αποτέλεσμα : 14

      2. Εκφώνηση : ' δύο βάλε κόμμα τρία βάλε κόμμα τέσσερα βάλε κόμμα πέντε '
        Αποτέλεσμα : 2, 3, 4, 5

    • Επιλογή 'Words':
      1. Εκφώνηση : ' δύο τρία τέσσερα πέντε '
        Αποτέλεσμα : δύο τρία τέσσερα πέντε

      2. Εκφώνηση : ' δύο βάλε κόμμα τρία βάλε κόμμα τέσσερα βάλε κόμμα πέντε '
        Αποτέλεσμα : δύο , τρία , τέσσερα , πέντε

    Πρέπει τέλος να αναφερθεί ότι δεν είναι δυνατό με την επιλογή της αριθμητικής απεικόνισης να παρασταθούν αριθμοί μεγαλύτεροι του 'δύο δισεκατομμύρια ' ( 2.000.000.000 ) .

    Στο κάτω μέρος του παραθύρου μπορεί κάποιος τσεκάροντας το τετράγωνο 'Supress intermediate results ' , να επιλέξει αν θέλει τη μη εμφάνιση των ενδιάμεσων αποτελέσμάτων που αλλιώς εμφανίζονται με κόκκινο χρώμα κατά τη διαδικασία της αναγνώρισης.


Μενού εντολών - Εργαλεία

Μενού

File | Το μενού αυτό περιλαμβάνει εντολές που διαχειρίζονται αρχεία
Edit | Το μενού αυτό περιλαμβάνει εντολές μορφοποίησησς κειμένου
Tools | Το μενού αυτό περιλαμβάνει βοηθητικές εντολές
Options | Το μενού αυτό περιλαμβάνει επιπρόσθετες επιλογές
Help | Το μενού αυτό είναι για παροχή βοήθειας

Εργαλειοθήκη

Συντομεύσεις εντολών διαχείρισης αρχείων
Συντομεύσεις εντολών μορφοποίησης κειμένου
Επιπλέον εντολές μορφοποίησης κειμένου
Συντομεύσεις εντολών που αφορούν στην αναγνώριση φωνής ή στην ηχογράφηση


Διαχείριση Αρχείων

Εντολές Διαχείρισης Αρχείων

Εντολή New

Στο μορφοποιητή κειμένου εμφανίζεται ένα καινούριο κενό αρχείο.

(Συντόμευση : Ctrl + N )

Εντολή Open...

Εμφανίζεται παράθυρο πλοήγησης στο σύστημα αρχείων του υπολογιστή του χρήστη με τη βοήθεια του οποίου μπορεί να επιλεγεί ένα υπάρχον αρχείο (απλό κείμενο - .txt - ή εμπλουτισμένο - .rtf- ) .

Το επιλεχθέν αρχείο εμφανίζεται στη συνέχεια στο μορφοποιητή κειμένου .

(Συντόμευση : Ctrl + Ο)

Εντολή Save

Αποθηκεύεται το αρχείο που είναι τρέχον στο μορφοποιητή κειμένου. Η αποθήκευση γίνεται χωρίς ο χρήστης να μπορεί να αλλάξει το όνομα του αρχείου ή την μορφοποίησή του (απλό κείμενο ή εμπλουτισμένο). Η δυνατότητα αυτή παρέχεται μόνο την πρώτη φορά που αποθηκεύεται το αρχείο ή με την εντολή Save As...

(Συντόμευση : Ctrl + S)

Εντολή Save As...

Εμφανίζεται παράθυρο πλοήγησης στο σύστημα αρχείων του υπολογιστή του χρηστή με τη βοήθεια του οποίου μπορεί να επιλεγεί ένα συγκεκριμένο μονοπάτι και όνομα για να αποθηκευτεί το τρέχον αρχείο στο μορφοποιητή κειμένου. Επιπλέον, είναι δυνατή η επιλογή αποθήκευσης του αρχείου στη μορφή απλού κειμένου ή εμπλουτισμένου.

Εντολή Print

Εκτύπωση του τρέχοντος αρχείου στο μορφοποιητή κειμένου μετά από ενδεχόμενη ρύθμιση των σχετικών παραμέτρων του εκτυπωτή με τη βοήθεια κατάλληλού παραθύρου.

(Συντόμευση Ctrl+P)

Εντολή Exit

Με την εντολή αυτή επιτυγχάνεται τερματισμός του προγράμματος. Αν το τρέχον αρχείο στο μοροφοποιητή κειμένου δεν έχει αποθηκευτεί τότε εμφανίζεται κατάλληλο προειδοποιητικό μήνυμα που προτρέπει το χρήστη να αποθηκεύσει το αρχείο πριν την έξοδό του από το πρόγραμμα.

(Συντόμευση Alt+X)


Μορφοποίηση Κειμένου

Εντολές Μορφοποίησης Κειμένου

Εντολή Undo

Με την εντολή αυτή αναιρείται η πιο πρόσφατη μορφοποίηση του τρέχοντος κειμένου είτε αυτή προαγματοποιήθηκε με τη βοήθεια εντολών είτε με το πληκτρολόγιο.

(Συντόμευση Ctrl+Z)

Εντολή Cut

Με την εντολή αυτή αποκόπτεται από το τρέχον αρχείο το επιλεγμένο τμήμα κειμένου και είναι διαθέσιμο για να τοποθετηθεί κάπου αλλού.

(Συντόμευση Ctrl+X)

Εντολή Copy

Με την εντολή αυτή το επιλεγμένο τμήμα κειμένου στο μορφοποιητή γίνεται διαθέσιμο για αντιγραφή σε κάποιο άλλο σημείο.

(Συντόμευση Ctrl+C)

Εντολή Paste

Με την εντολή αυτή είναι δυνατή η επικόλληση τμημάτων κειμένου που έχουν αντιγραφεί είτε από άλλη εφαρμογή είτε από το μορφοποιητή κειμένου του προγράμματος. Η επικόλληση γίνεται στο σημείο όπου αναβοσβήνει ο δρομέας στο χώρο του κειμένου, ή πάνω σε ένα επιλεγμένο τμήμα κειμένου.

(Συντόμευση Ctrl+V)

Εντολή Font...

Εμφανίζεται παράθυρο με τη βοήθεια του οποίου είναι δυνατός ο προσδιορισμός διαφόρων χαρακτηριστικών του τμήματος κειμένου που έχει επιλεγεί στο μορφοποιητή.

Ο χρήστης μπορεί να επιλέξει :

  • γραμματοσειρά :η επιλογή μπορεί να γίνει από το σύνολο των γραμματοσειρών του συστήματος (Συντόμευση : )

  • στιλ γραμματοσειράς:
    1. Regular - Κανονική γραφή (Συντόμευση : )
    2. Italic - Πλάγια γραφή (Συντομεύσεις : Ctrl+I , [image])
    3. Bold -Έντονη Γραφή (Συντομεύσεις : Ctrl+B, [image])
    4. Bold Italic - Έντονη Πλάγια Γραφή (Συντόμευση : )

  • μέγεθος γραμματοσειράς : (Συντόμευση [image] )

  • χρώμα (Color)

  • επισήμανση (Strikeout)

  • υπογράμμιση (Underline ) : Υπογραμμίζεται το κείμενο που έχει επιλεγεί (Συντόμευση : )

Εντολές Στοίχισης του Κειμένου

  • Το επιλεγμένο κείμενο στοιχίζεται αριστερά .
  • Το επιλεγμένο κείμενο στοιχίζεται στο κέντρο .
  • Το επιλεγμένο κείμενο στοιχίζεται δεξιά .

Εντολή εισαγωγής bullets

Με την εντολή αυτή το επιλεγμένο κείμενο εμφανίζεται με τη μορφή λίστας .


Βοήθεια για το πρόγραμμα

Βοήθεια

Εντολή Contents

Εμφανίζεται το παρόν αρχείο βοήθειας.

Εντολή About...

Εμφανίζεται παράθυρο με πληροφορίες σχετικές με την αναγνώριση φωνής γενικά και τον Ηλεκτρονικό Λογογράφο ειδικότερα.

Εντολή Recognition Demo

Αρχίζει επίδειξη της λειτουργίας του συστήματος. Αρχικά ακούγεται ένα ηχογραφημένο κείμενο και στη συνέχεια αναγνωρίζεται από τον Ηλεκτρονικό Λογογράφο και εμφανίζεται στην οθόνη.